MDIGITS - Counting Digits

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit.

For example, if a = 1024 and b = 1032, the list will be 1024 1025 1026 1027 1028 1029 1030 1031 1032 there are ten 0s in the list, ten 1s, seven 2s, three 3s, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line 0 0.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc

Sample output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

Note : wrong dataset index, rejudged and TLE some ACed code.


Được gửi lên bởi:psetter
Ngày:2009-02-22
Thời gian chạy:1s
Giới hạn mã nguồn:50000B
Memory limit:1536MB
Cluster: Cube (Intel G860)
Ngôn ngữ cho phép:Tất cả ngoại trừ: ERL GOSU JS-RHINO NODEJS PERL6 PYPY RUST SED VB.NET
Nguồn bài:Shanghai 2004

hide comments
2018-06-28 21:28:26 Vu Duy Truc
easy
2018-06-04 05:39:59
Viết các số từ a đến b
tính số lượng các chữ số
2 kết quả này output như thế nào vậy

Last edit: 2018-06-04 05:41:05
2016-05-25 07:36:58 Sue
Sau 1 năm rưỡi làm lại thì đấm lại 1 phát chết luôn :3
2014-11-16 16:58:46 Sue
nhìn rất dễ :v
và cuối cùng chạy quá lâu :v
2014-10-11 11:20:43 win_XP
bài này ngoài những test trong đề bài còn trường hợp nào đặc biệt ko ta?????????????


Last edit: 2014-10-11 11:21:05
2014-07-24 00:54:03 phu
các ac cho e hỏi chương trình của thử bằng devc++ ok mà trên này lại bị lỗi
Counting Digits
#include<iostream>
using namespace std;
int main()
{
int a,b,i,j,k;
int day[1000];
int dem[10]={0,0,0,0,0,0,0,0,0};
cin>>a>>b;
for(i=0;i<=b-a;i++)
{
day[i]=a+i;
while(day[i]>0)
{
k=day[i]%10;
day[i]/=10;
dem[k]+=1;
}
}
for(j=0;j<=9;j++)
{
cout<<dem[j]<<" ";
}
return 0;
}




2014-06-29 17:52:35 Phạm Quốc Du Thiên
Dùng cây để tính
2013-07-11 03:16:01 Thủ khoa vãn
sieu bua
2013-06-25 14:07:29 a;slkfjasl;fkj
Sau bao nhieu cong suc, cuoi cung cung lam duoc va dam phat chet luon :))

Last edit: 2013-07-03 15:29:51
© Spoj.com. All Rights Reserved. Spoj uses Sphere Engine™ © by Sphere Research Labs.